Go Back   Provoscooter.com | Forums > New Vespa, Honda & Vento > Vento Scooters > General Vento Questions

Reply
 
Thread Tools Display Modes
  #1  
Old 04-18-2006, 09:59 AM
vibrantglow vibrantglow is offline
Noob
 
Join Date: Apr 2006
Location: Boca Raton
Posts: 1
Default Triton GT5 Gauge Problem

I just picked up a 2006 Vento Triton GT5 last Saturday, and everything's been great.

Yesterday, I noticed a problem with the gauges. The speedometer reads a constant 00 and does not display the odometer either. The tachometer on the other hand is working fine.

Before I have to go down to the dealer, I was wondering if there's anything I should check.

Thanks for your help.
Reply With Quote
  #2  
Old 04-18-2006, 11:19 AM
VINOGT's Avatar
VINOGT VINOGT is offline
Member
 
Join Date: Mar 2005
Location: Bloomington
Posts: 258
Default

Just have the cluster replaced. It seems to be a common problem on the GT5 model. I had mine replaced also. It's been fine since then.
__________________
2007 Vintage 150cc(Joker clone). High output coil, iridium plug, high flow fan, air scoop for fan. More on the way.
Reply With Quote
  #3  
Old 04-18-2006, 10:59 PM
Iceman's Avatar
Iceman Iceman is offline
Member
 
Join Date: Mar 2005
Location: Durham, NC
Posts: 398
Unhappy

It is definitely a problem in the gauges. I am on my third one and even it acts up radomly. I am awaiting a reply from Vento USA now. I am thinking about installing the cluster from a regular Triton r4i as my tach is going crazy mostly and I can live without the tack but not the speedometer. They should replace it under warranty. I have heard of a lot of folks having this problem but I seem to be the only one that new ones keep failing. Otherwise a great scooter. Good luck.

Mike
Reply With Quote
  #4  
Old 04-20-2006, 02:26 AM
Hawaii 50's Avatar
Hawaii 50 Hawaii 50 is offline
Member
 
Join Date: Jan 2005
Location: Kona, HI
Posts: 116
Default

I just installed my stage one and now the tach starts to drop off right around 9900-10,000 rpm. It just starts rolling back and stops at zero.
__________________
2005 Vento Triton GT5 - Polini Corsa/R, Polini EVO crank, RS Pipe, Arreche 19mm, Needle clip in middle, 100 main jet, Polini EVO Variator and finned outer pulley, Malossi Yellow Torque Spring, Malossi Carbon Fiber Reeds w/spacer, Delta Clutch w/red springs, Wing Bell, 5gm weights
Reply With Quote
  #5  
Old 04-23-2006, 02:01 PM
BFech BFech is offline
Noob
 
Join Date: Apr 2006
Location: Green Bay
Posts: 2
Default

I bought my gt5 back in june of 2005. The digital gauges went out after the first week. Then the fuel sensor broke. Luckily each item was under warantee
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump